Something strange seems to be happening. Last week the problems started around wednesday.
I started max2008 and vray didn’t work anymore. License could not be obtained from the server. However, I can read the dongle with the wibukey control panel. Still, I get the errorcode -98 when I try to render in Max2008-64bits.
The same dongle works fine on max9-32b.
On max2008 32-bits I also get an errorcode, but in this case it’s -7.
Hopefully some recognizes this and knows how to fix it…
I would say the service is running as it should, because vray for max9 is working fine…
I checked the eventviewer, there were 3 errors, but those were from a corrupted installer when I tried to reïnstall. (After that I downloaded the latest version again which worked fine)
The ( -98 ) error would happen only if you try to connect to a vrlservice for a different modification of V-Ray (e.g. EDU or NFR); the ( -7 ) code could happen if the vrlservice and V-Ray itself are from different versions (e.g. V-Ray is SP1, but the license server is older).
All used vray installations are 1.50 SP1 NFR. The only difference being the max versions (max9/max2008 ) and the bits versions (32/64 bits).
That is, the 64-bits version on max2008 is on a different system and gives the (-98 ) error.
The (-7) might be triggered by a difference in 32-bits vray for max9 and the same version for max2008?
It’s all I can think of…let’s test…ok, so the (-7) is solved, wrong license server (they all look alike ).
Still the (-98 ) would mean I have a license server for NFR and a different installation for vray?
That would be strange, it’s a clean install…I reinstalled it again, just to be sure, it’s the only installation of vray on this system. It’s using Vista Ultimate 64-bits, max2008-64-bits, and vray 1.50 SP1 NFR for max2008 x64…
Any idea how I might fix this one?
When you connect to that license server from a web browser on the machine that gives the -98 error, (e.g. http://licenseserverIP:30304/) and click on the “get status” link, towards the bottom of the page there will be information what kind of license server this is (e.g. ADV, NFR, EDU). Does this correspond to the V-Ray build that you have installed on the machine?
The default access is OK, I think; in that case, could you try the following: try rendering an image from the failing machine; immediately after that open a web browser and enter as the address http://licenseserverIP:30304/getlog/ then save the resulting file and email it to me at vlado@chaosgroup.com so that I can take a look as to why the license was refused.
Got kind of the same problem
Got 7 workstations (dual-core, windows XP x86, Max9/2008, vRay15sp1), 14 render nodes (dual-core, windows XP x86), and dongle and license server installed on a Windows Server 2003 x86 machine.
Works like a charm.
We just bought an dual quad-core, 8gb workstation with Vista x64 installed.
Installed Max 2008 and vRay. But it can’t obtain a license?
No firewall or anything obstructing the connection…
Well, the problem of RayOfLight turned to be entirely different (wrong dongle); for your case - are you able to connect to the license server via a browser from the new machine? Is the license server also the latest version?
Yeah, just figured it out for myself, updated the license server on the server with the one from vray_adv_150SP1_max2008_x86.exe.
Everything is working fine now, can obtain license fra both winXP x86,vista x64, Max9, Max 2008 in any combination.