I assume this has already been discussed to death, but someone could help me clear up my question.
Simply, we’d like to set up an alternate Vray license server in case the primary server doesn’t work properly, but it seems the manual doesn’t include how to do it.
Can someone tell me how to do it? Do we need to get a dongle for the alternate server as well (I think so.)?
If you have more than 1 license, you can split these across two or more dongles, put them on different machines and set up license servers on them. Then you can specify the different machines as alternative license servers.
We have 14 licenses, and we use all the 14 licenses almost always.
Do you mean by “split these” that setting up seven licenses on a license server and the other seven lisences on another license server? This way, we would be unable to use seven licenses if one server gets down.
We need to secure all the licenses all time. Can we do it?
Sounds like you want fault tolerance for the license server in case the machine has a hardware failure. I do not think there would be a way to share your 14 across two machines however I think the best solution is two have two exact copies of machines and then you could just swap the dongle incase of a failure. This still leaves the dongle as a failure point but would at least backup everything else.
Thanks for the note. Yeah, I wanted to set up a fault tolerance system, and I had also thought of the idea that having two exact copies of two machines as you suggested. But again, someone has to swap the dongle in case of a failure.
Unfortunately, the idea that having exact copies of machines isn’t really the best solution to us because it requires someone authorized to access the server room all time while our co-workers often work during night and weekend. Also, while we had already set up a fault tolerance system for other software, this idea requires another backup server just for Vray. (It’s at least better than having nothing to backup, though.).
So, I just wanted to know if there is a way to set up a fault tolerance system while we can do it for 3Ds Max. No way for Vray?
Thanks for the note, Derik.
That’s disappointing to know, though…
Since it’s VERY important to meet the deadlines, we can never make Vray unavailable in our office. I strongly hope the fault tolerance will become available in the near future while it costs nearly as much as USD1,000 per license.
One thing I didn’t under stand as being clear from this is whether or not you need to have fault tolerance for network rendering or just workstations. We put 1/2 of our lics on pne dongle attached to the file server and this is referenced by the network and 1/2 of our workstations. We have another file server that has one lic on it’s dongle and this serves one work station and is the back up for the render farm. All machines the are workstations also reference the file server with the 10 lics on it as a backup considering not everyone is running VRAY at all times.
Cheers
Mike K
How does the Alternate License Servers work? We have 4 licenses split between our two offices and use Hamachi to link each other. I would like to have the primary server pointing to the in-office server and the alternate license server pointing to the remote office. I can access the remote office license server if I enter it into the Primary License server, but doesn’t work if I put it in either of the alternate server spots. What am I missing here?
“Could not obtain a license (1002).” We’re running 1.5SP3a
Attached is a screen cap of the settings I’m using. “192.168.0.216” is local “5.162.3.243” is the remote server.
Looks like we will need to modify the license server for this to work; right now the alternate license server is only used if V-Ray cannot connect physically to the primary server. In your case however, V-Ray can successfully connect to the primary server, but there aren’t free licenses left on it. I’ll see how easy it will be to make the modification.
Thanks for looking into this Vlado. Surprised I’m one of the first one’s to try and do this - or at least post about it. This will only be temporary - the other office’s lease is up in a year and we will be combining into one larger brand new office
I also have my license setup with hamachi and have that same problem. Only the primary license server works, the alternate is ignored. I always thought about posting about it but never got around to. I just manually enter the info in the primary server to get it to work, but it would be perfect if there was a way to modify the license server to be able to use the alternate license server in these cases.
Hi Vlado,
was this ever fixed? We have 12 licenses on 2 dongles on remote server, but need failover (w/o buying 12 more licenses!). Is this possible now?
thanks